2015年8月1日土曜日

Eclipse での Dart製 Chrome app の開発

Chrome app 開発用に, DartEditorからEclipseに移行しました

DartEditorの開発が止まったので、Eclipseに移行しました。選択肢として WebStormを使うことも検討したのですが、 WebStormでのDart製のChromeアプリの開発が面倒だったので、Eclipseを利用することにしました。

- 標準でChrome アプリ用のテンプレートが含まれていない
- 標準でmanifest.json を右クリックからの動作確認ができない

Eclipseならば、簡単につかえます。

 
 
 

インストールが不便

しかし、素直にEclipseのインストールが上手できなくて、結構苦労しました。Dartiumを認識させ方が不明。Eclipseが起動しなくなるとか。

軽くEclipseでの環境の設定方法について解説したいと思います。
 
 
 

EclipseをInstallしよう

eclipse を手に入れましょう。僕はJava Developers版を利用しました。をhttp://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/marsr

選んだ理由は、余計なものが入っていなさそうだから。
 
 
 

Dart plugin をインストールしよう

1. Menu:Help --> Install New software..
2. addボタンを押す。Add Repositoryダイアログが表示される。
3. Nameをdartrepo. Locationを"http://www.dartlang.org/eclipse/update/channels/stable/"にして、OKボタンを押す。
4. Work with をdaerreoにする。自動でそうなるはず。
5, 表示されたものを選択して、Nextボタン等をおして、後は指示に従って進めてください。

 
 

Dart SDK をインストール

Dart SDK はプラグインからダウンロードできます。
1. Menu:Windows --> Preferences 。Preferencesダイアログが表示される。
2. Dart-> SDK
3. Dart SDK のところの、Downloadボタンを押してください

※ Preference Dialogに、 "Install at C:.asfas/asdfas/asdf/dart-sdk"といった感じでパスが表示されています。ここにインストールされます。
 
 
 

Dariumをインストールする

Dartiumをインストールします。https://www.dartlang.org/tools/dartium/ で手に入ります。zip圧縮されているので、解凍してください、
Preference Dialogに表示されている、"Install a c://aaa/aa/chromium"で指定されたフォルダーのの直下に、chrome.exeがある状態にしてください。



PS

これで、完了です。今回試した環境は以下の通り
Microsoft windows surface pro2 (8G memory, windows8) 
 
DartEditorはインストールすれば直ぐに使えてお勧めだったんだけど、開発が停止してしまった。
Dart Teamが推しているWeb Stormは有料だし、デフォルトでChrome App開発機能がない。
僕は、Eclipseが良いと思っている。

 
 

-------
Kyorohiro work



0 件のコメント:

コメントを投稿